Asdoc tasl generate error with '-include-namespace' compile property

Andrei Starodubctev's Avatar

Andrei Starodubctev

27 Jan, 2016 09:29 AM

I built swc libarary with additionalCompilerOptions = ["-namespace+=${ext.namespace},${projectDir.path}/src/main/resources/manifest.xml",
        "-include-namespaces=${ext.namespace}"]

Also I try to generate asdoc documents and get error: "command line: Error: unknown configuration variable 'include-namespaces'"

asdoc {
    additionalASDocOptions = [
            "-doc-namespaces=${ext.namespace},${projectDir.path}/src/main/resources/manifest.xml"
    ]
}

How I can set additional compiler options only for asdoc. I tried to insert additionalCompilerOptions array without '-include-namespaces' into asdoc configuration and this broke main task compileFlex.

Thanks for help

  1. 1 Posted by Andrei Starodub... on 27 Jan, 2016 12:10 PM

    Andrei Starodubctev's Avatar

    I found workaround:
    asdoc {
        project.tasks.findByName('asdoc').doFirst {
            additionalCompilerOptions = [<set options only for asdoc>]
        }

        additionalASDocOptions = [
                "-doc-namespaces=${ext.namespace}"
        ]
    }

    But it is looks ugly. I can't call asdoc task because asdoc configuration and asdoc task have same names.

    My suggestion is in asdoc task using only additionalASDocOptions without additionalCompilerOptions.

  2. Support Staff 2 Posted by Yennick Trevels on 31 Jan, 2016 05:06 PM

    Yennick Trevels's Avatar

    Hi Andrei,

    Indeed, you're right, I've created a ticket for it in our issue tracker: https://github.com/GradleFx/GradleFx/issues/225

    Currently your workaround is the only way to get this working.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

24 Mar, 2017 07:10 PM
19 Mar, 2017 04:39 AM
22 Jan, 2017 07:46 AM
11 Oct, 2016 01:18 PM
20 Sep, 2016 04:36 PM

 

06 Sep, 2016 08:05 PM
03 Aug, 2016 11:15 AM
01 Jun, 2016 05:20 PM
03 May, 2016 09:17 PM
07 Apr, 2016 07:43 AM
24 Mar, 2016 05:55 PM