1401 Should be part of the Framework.

Rus's Avatar

Rus

29 Jul, 2014 11:22 PM

I am using the following config which is below. When compiled via IntelliJ evreything works as expected and the SWF is around 1MB when using gradle the SWF is 500mb. And I get a missing class error. Error #1014: Class flash.events::DRMReturnVoucherCompleteEvent could not be found. Which is in FP player 11.8+ and I tried 12 and 14 by setting the target player. I also tried setting the swf version in the comp options with no luck. It feels like there is something that is not getting merged in.

`buildscript { repositories { mavenCentral() } dependencies { classpath group: 'org.gradlefx', name: 'gradlefx', version: '0.8.2' } }

apply plugin: 'gradlefx'

type = 'swf'
version = '2.6.0-SNAPSHOT'
output = 'PlayerPlatformAPI'
mainClass = 'com/project/main.as'
frameworkLinkage = 'merged'

repositories {
ivy { name 'Apache' artifactPattern 'http://archive.apache.org/dist/flex/[revision]/binaries/[module]-[r...; } ivy { name 'Adobe Air SDK' artifactPattern 'http://download.macromedia.com/air/win/download/[revision]/[module]...; } }

dependencies {
flexSDK group: 'org.apache', name: 'apache-flex-sdk', version: '4.12.1', ext: 'zip' airSDK group: 'com.adobe', name: 'AdobeAIRSDK', version: '4.0', ext: 'zip' merged fileTree(dir: 'libs', include: '*.swc') }

sdkAutoInstall {
showPrompts = false }

additionalCompilerOptions = [
'-target-player=14.0', '-strict=true', '-debug=false', '-optimize=true',

]

srcDirs = [
"src/" ]`

  1. 1 Posted by Rus on 30 Jul, 2014 05:02 AM

    Rus's Avatar

    Got it resolved apparently SWF version is not one to one mapping to flash player version. Here is the most up to date table for any one else who might hit this.

    "SWF Version" | "Flash Player Version"

       9       |          9
      10       |      10.0, 10.1
      11       |         10.2
      12       |         10.3
      13       |         11.0
      14       |         11.1
      15       |         11.2
      16       |         11.3
      17       |         11.4
      18       |         11.5
      19       |         11.6
      20       |         11.7
      21       |         11.8
      22       |         11.9
      23       |         12.0
      24       |         13.0
      25       |         14.0
    
  2. Support Staff 2 Posted by Yennick Trevels on 30 Jul, 2014 05:47 AM

    Yennick Trevels's Avatar

    Do you still have the 500mb file problem? While 1MB for Intellij is almost nothing (it's probably optimised for development purposes only), 500MB for Gradle shouldn't be happening.

  3. 3 Posted by Rus on 30 Jul, 2014 05:50 AM

    Rus's Avatar

    That was a typo should have been 500Kb so we are all good.

    I do have one follow up questions. When setting the type to SWF the asdoc task is not available is there any setting I can set to still generate it?

    Also is there a way to generate both an SWF and SWC the code base is an API so it can be used as SWF and SWC.

  4. Support Staff 4 Posted by Yennick Trevels on 30 Jul, 2014 06:02 AM

    Yennick Trevels's Avatar

    To generate both a SWF and SWC I'd suggest to split up your project, where one subproject has the API code, and the swf subproject uses that API project to wrap it in a swf. It isn't possible to generate both a SWF and SWC from the same project.

    ASDoc is only available for library (swc-based) projects. This is because such documentation is generally only used for libraries, not for an end-user application.
    But if you split up your projects in a library project (for the API) and an end-user project (for the SWF) then you can generate ASDoc for the library project.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

24 Jun, 2017 02:18 PM
10 Jun, 2017 04:16 PM
24 Mar, 2017 07:10 PM
19 Mar, 2017 04:39 AM
22 Jan, 2017 07:46 AM

 

11 Oct, 2016 01:18 PM
20 Sep, 2016 04:36 PM
06 Sep, 2016 08:05 PM
03 Aug, 2016 11:15 AM
01 Jun, 2016 05:20 PM
03 May, 2016 09:17 PM